[BioPython] AlignIO: Sequences of different length

João Rodrigues anaryin at gmail.com
Mon Dec 8 18:26:36 EST 2008

Well, as promised, here goes update. I didn't try with soaplab2 because it
was too complicated to get it to work. I didn't want to lose more than 10
minutes either so... However, with standalone needle, which EBI claim to be
the same version as the soaplab2 service, it works flawlessly :)

Code here: http://pastebin.com/f29ff12d6

Console output here: http://pastebin.com/f5bbc5593

It's not a bug then, it's just an old version :) Using the web versions,
there may be some workarounds. If you convert the format to one of the
others, you may get a usable one for Biopython. I tried markx1 I believe,
and it was "almost" parsable, it just didn't get the correct sequences (if
you deleted everything BUT the sequences, it would work). So, I think there
should at least be a warning somewhere for the users so that they don't get
nuts or reporting bugs :)

Thanks for all the help!


João Rodrigues

On Fri, Dec 5, 2008 at 2:59 PM, João Rodrigues <anaryin at gmail.com> wrote:

> Well... My VISTA partition just erased my Linux one, don't know how, so I
> can't answer that right now :x As soon as I get linux again, as soon as I
> get my script written again, I'll give an update here :) But I had solved
> the problem by changing the alignment output format to markx10 and "parsing"
> it my own way.
> Cheers and thanks for the help :)
> João Rodrigues
> http://doeidoei.wordpress.com
> On Fri, Dec 5, 2008 at 12:18 PM, Peter <biopython at maubp.freeserve.co.uk>wrote:
>> On Fri, Dec 5, 2008 at 11:34 AM, João Rodrigues <anaryin at gmail.com>
>> wrote:
>> > I got a reply from the EBI support team saying that the webserver they
>> > provide is outdated, when compared to the versions of NEEDLE we (me on
>> the
>> > web and Peter on his local machine) used. So, BioPython is nice and
>> > up-to-date, it's their server that is quite outdated.
>> >
>> > " Actually the WSEmboss web service uses an older version of EMBOSS
>> (2.9.0),
>> > which exibits this behaviour. I suggest you contact the BioPython folks
>> and let
>> > them know that older versions of EMBOSS behave differently.
>> >
>> > If you want to use the latest version of EMBOSS I suggest looking at
>> using
>> > the Soaplab services (see
>> http://www.ebi.ac.uk/Tools/webservices/soaplab/overview)
>> > instead.
>> >
>> > All the best,
>> >
>> > Support at EBI"
>> >
>> > João Rodrigues
>> Thanks the update :)
>> Are you OK using the more up to date SOAP needle, or perhaps standalone
>> needle?
>> Does thos

More information about the BioPython mailing list